Connection to SMB/UNC storage without a password or using guest access fails: "The specified network password is not correct" or "Your organization's security policies block unauthenticated guest access"

Symptoms

  • When connecting to SMB/UNC storage with an empty password field, connection fails with the error messages:

    CONFIG_TEXT: The user name or password is incorrect,
    Creating the directory failed because the specified path is invalid,
    The specified network password is not correct.

  • When connecting to SMB/UNC storage using guest access, connection fails with the error message:

    CONFIG_TEXT: You can't access this shared folder because your organization's security policies block unauthenticated guest access. These policies help protect your PC from unsafe or malicious devices on the network.

Cause

A Windows update has made password-less and guest logins to SMB servers unsupported by default.

Resolution

Apply one of hte following solutions:

Solution 1

Add a password to the SMB user, and add it to the password field in Comet.

Solution 2

Change the default behaviour of the endpoint by modifying the registry:

  1. Start Windows Registry Editor: press Win + R and type regedit.
  2. In regedit, open HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters.
  3. Right-click and select New > DWORD (32-bit) Value with the name AllowInsecureGuestAuth.
  4. Double-click on AllowInsecureGuestAuth and set the value data to 1.
  5. Close the Registry Editor and reboot the device.
Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.